Testing MAPI Function

Nov 2, 2009 at 4:08 PM

        I am a novice with this MFCMapi tool - Please help!

I was having troubles restoring a Public Folder using backup excec - Backup Exec was giving Mapi errors and basically points towards an article that tells you how to use this MFCMapi

tool; to test MAPI is working correctly on exchange.

The instructions tell me to double click on the tool, then go to 'Session>Logon and Display store Table'

When I do, I get the following error:

"Error: The specified procedure could not be found.

Code: 0x8007007F == 0x8007007F
Function pfnFGetComponentPath( szComponent, szQualifier, szDllPath, cchDLLPath, TRUE)
File .\ImportProcs.cpp
Line 327"

When I press ok, it brings up the profile screen, but the above message doesn't look good!?

Thanks in advance,


Nov 2, 2009 at 4:16 PM

Sounds like the installation of MAPI on this box is messed up.

Is Exchange installed on this box? If so, which version?

Is Outlook installed on this box? If so, which version?

Is the MAPI download installed on this box?

Can you locate c:\Windows\System32\mapi32.dll and report the version number?

Nov 3, 2009 at 8:21 AM

Hi Sgriffin,
            Thanks for your response.

1: Yes, exchange installed on this box (2003 SP2 (Version 6.5.7638.1))

2: Didn't know it was, but yes, outlook is also installed on our exchange box.

3: The MAPI download? I am running the "MFCMapi.exe" tool from a folder on the desktop.

4: The version number of mapi32.dll is 6.5.7654.12

Thanks again for any response,


Nov 3, 2009 at 10:21 AM

Yeah - you can't install Outlook on an Exchange 2003 box and expect MAPI to work. Outlook needs to come off that box. You might need to reinstall Exchange to get MAPI working again.

Nov 3, 2009 at 10:50 AM

Eeek - Thanks sgriffin. In light to your response, here is a URL for any others that come across this post


Which, happens to be a blog by you!