Oct 22, 2013 at 2:39 PM
Hi MFCMAPI Community,

We have a third party software which is accessing the mailboxes via MAPI. Now I have the MAPI_E_FAILONEPROVIDER == 0x8004011D error on my Exchange 2010 SP3 when I try to access the mailbox via MFCMAPI. I can access the Public Folder Database, but not the specific mailbox. The user is a domain admin account. The software worked before with Exchange 2010 SP1. The software developer was already remote supporting and concluding it is a Microsoft issue. I already tried to set "Ignore No PF" DWORD under HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows Messaging Subsystem\CDO. But this has no result. Besides we have public folders.

I already installed all UR patches and still no luck. Any help would be appreciated.

Oct 30, 2013 at 3:46 PM
Any suggestions on this one? It is also not possible to connect with Outlook 2003 SP3 to the desired mailbox. It is possible to connect to a different mailbox.

Nov 14, 2013 at 10:28 AM
Problem solved:

We had incorrect acl permissions on the domain admin account. In our case FullAccess was denied on the top entry of the acl permissions. Further down there was also a correct entry with the necessary permissions. I had to remove the top acl entry from the account acls.
  1. get-mailboxPermission | FL
  2. enter domain account
  3. remove the faulty acl permission with cmdlet: Remove-mailboxpermission Account -user domain\Account -AccessRights FullAccess -deny:$true
Marked as answer by SMCIT on 11/14/2013 at 3:28 AM