This project has moved. For the latest updates, please go here.
1

Closed

Repeated APPCRASH, upon trying to access profiles etc. in Win10 x64

description

I tried setting the verbose option and enabling the logfile; but no logfile is created.
APPCRASH reports are attached here, in a .zip file.

file attachments

Closed Feb 17 at 7:05 PM by sgriffin

comments

sgriffin wrote Feb 6 at 6:29 PM

What are your repro steps and what version of MFCMAPI are you running? What version of Outlook do you have installed?

lcarver wrote Feb 6 at 7:02 PM

This is the (latest available?) MFCMAPI x86 version 17.0.17033.02
I launched it, then I clicked on Profile .. Show Profiles .. (and it crashed)
I launched it, then I clicked on Session .. Logon .. (and it crashed)
I launched it, then I clicked on Profile .. Advanced Profile .. Launch Profile wizard .. (and it crashed)

One dialog that did work is Tools .. Options ..

The Outlook client is Microsoft Outlook 2016 MSO (16.0.7668.7101) 32-bit

sgriffin wrote Feb 6 at 7:45 PM

Thanks - we don't repro here with a similar build. Do you repro on multiple machines or just the one? Do other applications which use MAPI (like Lync/Skype) have any issues? Do older builds of MFCMAPI have any issues?

lcarver wrote Feb 6 at 8:42 PM

Yes, I understand the issue I am experiencing must be unique to my setup. I would be glad to try an older build of MFCMAPI.
I don't have my Outlook profile on any other PC; but since other PCs have slightly different software configurations, I think if it does not crash there then I'll be immediately back on my original setup to pursue the issue.
What about the application crash logs, can we look for a clue there?

sgriffin wrote Feb 6 at 9:20 PM

All older builds of MFCMAPI are available for download on the downloads tab if you want to try them.

You should let the issue be reported and then look for the 1001 event in the event log. This will get you the Watson bucket, which I can then look up here. Or get a crash dump and share it to me.

Does the mail control panel also crash?

lcarver wrote Feb 17 at 4:56 PM

Hi Stephen, I'm sorry that I didn't reply on this for so long.
There had never been any crash when I used the Mail control panel.
The situation has changed now. This week I had a replacement of the system disk drive in my PC,
they put a fresh OS image on it ... all the same OS and library versions as before.
I believe that in some areas, my access rights are slightly better (fuller); that is one thing I had been complaining about.
The good news is that when I launch MFCMAPI.exe now, navigating through the GUI and browsing all sorts of objects in the profile and mail store, everything just works ... the application has not crashed at all. No problems.
The APPCRASH reports (attached) were all that I could really collect, about the problem ... sorry about that.
For my future experience, I would like to get in the practice of sending in the bucket numbers. I found a brief article which explained how I can do that ( https://blogs.msdn.microsoft.com/johnguin/2014/07/09/how-to-get-a-watson-bucket-number-for-windows-8 ).
I suppose we can close this issue (unreproducible, etc.). Thanks ... Larry

wrote Feb 17 at 7:05 PM