MFCMapi "sample version" ?

Apr 7, 2009 at 6:58 PM
Hello,
    This is my first time writing. I have downloaded the latest version (Mar 09) release of MCFMapi but when I got run it the title window comes up "MCFMAPI Sample Version" then explaining that this is not supported. I need to have the MCFMAPI installed as it is required for our backup software utitily IBM's newest TSM exchange client ver. 6.1.0. How can I get the "unsampled" MCFMapi?
Thanks Richard
Coordinator
Apr 7, 2009 at 7:01 PM
I doubt MFCMAPI is required for IBM's backup software. It's more likely that MAPI is required:
http://www.microsoft.com/downloads/details.aspx?familyid=E17E7F31-079A-43A9-BFF2-0A110307611E&displaylang=en
Apr 7, 2009 at 7:11 PM
Thank-you very much for replying so quickly.... I appologize, the instructions I was given is to use MFCMapi to add services to the mapisvc.inf file in order that the new TSM exchange client can perform brick level mailbox restores. Also, we are running exchange 2003.
Coordinator
Apr 7, 2009 at 7:38 PM
Then I would follow those instructions. Of course, if you're just looking to add entries to mapisvc.inf, it's just a text file. I'm surprised that client doesn't add the entries itself.
Apr 8, 2009 at 11:12 AM
Thank-you again, I looked at the mapisvc file then looked at the IBM TSM documentation supplied by our backup team and it looks relatively simple to modify the file. As I am fairly new working with exchange and according to our backup team they provided these instructions to perform on our Exchange 2003 servers below. This is how I found this codeplex site and the MFCMAPI tool, which we can use for other exchange tasks. As I stated earlier, I downloaded the latest version of MFCMapi (Mar09) and when I go to run it, the window comes up MFCMapi Sample Version. Is there any issues using the sample version or is there another version that is not in "sample mode"? Again, thank-you for your help and quick responses.

4. Perform these tasks to configure your system for

mailbox-level and item-level restore operations

To use the TSM Data Protection for Exchange mailbox restore feature, there are additional configuration requirements.

Exchange Server 2003 requirement

Exchange Server 2003 is provided with the Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 (MAPI) as a base product installation. However, for Exchange Server 2003 environments, you must update your local MAPI configuration file to perform mailbox restore operations to a .pst file.

If you are running Exchange Server 2003, use the Microsoft Exchange Server MAPI Editor (MFCMapi) to add the MAPI PST message service MSPST MS to your local MAPI configuration file, mapisvc.inf. Consult your Microsoft documentation for further details.

Exchange Server 2007 requirement

Exchange Server 2007 is not provided with the Microsoft Exchange Server MAPI.

If you are running Exchange Server 2007, install the Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 (or later) package on the Exchange Server that you will use to perform the mailbox restore operations. Consult your Microsoft documentation for further details.

Restriction: Do not install the Microsoft Outlook MAPI on any Exchange Server 2003 or Exchange Server 2007 machine that is used to perform Data Protection for Exchange mailbox restore tasks. Microsoft does not support installing the Microsoft Outlook MAPI with Exchange Server 2003, and does not recommend installing the Microsoft Outlook MAPI with Exchange Server 2007. Consult your Microsoft documentation for further details.

Do not install the Microsoft Outlook MAPI on any Exchange Server 2003 or Exchange Server 2007 machine that is used to perform Data Protection for Exchange mailbox restore tasks. Microsoft does not support installing the Microsoft Outlook MAPI with Exchange Server 2003, and does not recommend installing the Microsoft Outlook MAPI with Exchange Server 2007. Consult your Microsoft documentation for further details.

 

Verify that an Exchange Server is ready to perform mailbox

restore operations

Verify that your Exchange Server is ready to perform Data Protection for Exchange mailbox restore operations.

Exchange Server 2003 is provided the Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 (MAPI) as a base product installation.

However, for Exchange Server 2003 environments, you must update your local MAPI configuration file, mapisvc.inf, prior to performing mailbox restore operations to a .pst file.

Use the Microsoft Exchange Server MAPI Editor (MFCMapi) to add the MAPI PST message service MSPST MS to your local mapisvc.inf file. Refer to your Microsoft documentation for further details.

For Exchange Server 2007 environments, MAPI 1.2.1 or later must be installed on the Exchange Server that you will use to perform mailbox restore operations.

Use MFCMapi to verify your MAPI configuration. Refer to your Microsoft documentation for further details.

 

Coordinator
Apr 8, 2009 at 12:20 PM
There is no other version. You found the version they intended you to find.
Apr 8, 2009 at 1:39 PM
Thank-you for your help... I like this MFCMapi utility...