PR_PROVIDER_UID Err:0x8004010F=MAPI_E_NOT_FOUND when connecting to Exchange Server 2013 CU2

Dec 18, 2013 at 5:01 AM
I am trying to connect using latest MFCMAPI to Exchange Server 2013 CU2.
Although user's mailbox and public folders are fetched, i do see the error below:

Error is as shown below:
Property Name OtherNames Value
0x300C00A PR_PROVIDER_UID, PidTagProviderUid Err:0x8004010F=MAPI_E_NOT_FOUND
0x3D0C00A PR_SERVICE_UID, PidTagServiceUid Err:0x8004010F=MAPI_E_NOT_FOUND

Image
Coordinator
Dec 18, 2013 at 12:52 PM
That just means those properties didn't happen to be on whatever object you're looking at.
Dec 18, 2013 at 2:35 PM
Thanks Griifin for quick reply.
Is the object property need to be set on mailbox at Exchange Server?
Coordinator
Dec 18, 2013 at 2:58 PM
Is something not working?
Dec 18, 2013 at 3:01 PM
Edited Dec 18, 2013 at 3:21 PM
Yes, Griffin.

My application fails to connect to Exchange with below parameters, then i have tried using MFCMAPI to if everything is okay. MFCMAPI could connect with above errors.

And I have tried with program using below parameters, i still get network error from MAPI call. Can you kindly help, I can provide any additional details needed.

___ props[prop_count].ulPropTag = PR_PROFILE_UNRESOLVED_NAME;
    props[prop_count].Value.lpszA   = <ProfileUnresolvedName>;
    prop_count++;

    props[prop_count].ulPropTag     = PR_PROFILE_UNRESOLVED_SERVER;
    props[prop_count].Value.lpszA   = <mailboxGUID@domain.com>;
    prop_count++;

    // Setting this to TRUE causes OpenMsgStore() to fail with MAPI_E_UNCONFIGURED
    props[prop_count].ulPropTag      = PR_CONVERSION_PROHIBITED;
    props[prop_count].Value.b        = FALSE;
    prop_count++;

    props[prop_count].ulPropTag     = PR_PROFILE_CONFIG_FLAGS;
    props[prop_count].Value.l       = CONFIG_SERVICE /*| CONFIG_PROMPT_FOR_CREDENTIALS | CONFIG_SHOW_CONNECT_UI */;
    prop_count++;

    props[prop_count].ulPropTag     = PR_DISPLAY_NAME;
    props[prop_count].Value.lpszA   = <Mailbox Profile Name>;
    prop_count++;

    //Above setting used to be sufficient to connect using RPC
    //Below parameters added to connect via HTTPS
    LPSTR pwszUser = "domain\\username"; //also tried username@domain.com AND username
    LPWSTR pwszPassword = L"paswword"; // Password has been encrypted using CryptProtectData

    props[prop_count].ulPropTag = PR_PROFILE_RPC_PROXY_SERVER_W;
    props[prop_count].Value.lpszW = L"https://ProxyHostname.domain";
    prop_count++;


    props[prop_count].ulPropTag = PR_PROFILE_RPC_PROXY_SERVER_AUTH_PACKAGE;
    props[prop_count].Value.l = RPC_C_AUTHN_NONE;      // RPC_C_HTTP_AUTHN_SCHEME_NTLM, RPC_C_HTTP_AUTHN_SCHEME_BASIC
    prop_count++;

    props[prop_count].ulPropTag =  PR_PROFILE_RPC_PROXY_SERVER_FLAGS;
    props[prop_count].Value.l = PRXF_ENABLED | PRXF_SSL;// | PRXF_IGNORE_SEC_WARNING; // | PRXF_IGNORE_SEC_WARNING;
    prop_count++;

    props[prop_count].ulPropTag = PR_PROFILE_RPC_PROXY_SERVER_PRINCIPAL_W;
    props[prop_count].Value.lpszW = L"msstd:certificateserverhostname.domain";
    prop_count++;

    props[prop_count].ulPropTag = PR_PROFILE_AUTH_PACKAGE;
    props[prop_count].Value.l = RPC_C_AUTHN_GSS_NEGOTIATE;                // RPC_C_AUTHN_WINNT, RPC_C_AUTHN_GSS_NEGOTIATE, RPC_C_AUTHN_NONE
    prop_count++;

    props[prop_count].ulPropTag = PR_PROFILE_AUTH_USER_W;
    props[prop_count].Value.lpszA = pwszUser;
    prop_count++;

    props[prop_count].ulPropTag = PR_PROFILE_AUTH_PASSWORD;
    props[prop_count].Value.bin.lpb = dataBlobOut.pbData;
    props[prop_count].Value.bin.cb = dataBlobOut.cbData;
    prop_count++;

    DB( (DB_PR _T("ConfigureExchangeService() About to configureMsgService\r\n"), this ) );
    hres = lpServiceAdmin->ConfigureMsgService( exchUID, 0, config_flags, prop_count, props );___

    I still get MAPI_E_NETWORK not found
  1. Are there any configuration changes need to be done on Exchange Server?
  2. Is there any mistake in above parameters?

Kindly suggest.

Dec 22, 2013 at 9:13 PM
This call was successful when properties and values were set correctly.
Thank you,
Venky.