"MAPI_E_FAILONEPROVIDER == 0x8004011D" from OpenMsgStore with special exchange environment.

Oct 11, 2011 at 6:46 PM

I am getting error “MAPI_E_FAILONEPROVIDER == 0x8004011D”  when I try to open default store using OpenMsgStore function. I have 2010 exchange server but this exchange server does not have public folders.  I have tried with latest MAPIMFC and latest MAPICDO but getting same result. I have also used CONNECT_IGNORE_NO_PF but no luck.

I did follow below link:

http://blogs.msdn.com/b/stephen_griffin/archive/2007/03/19/mapi-and-exchange-2007.aspx

http://blogs.msdn.com/b/dvespa/archive/2009/09/02/how-to-configure-a-mapi-profile-to-connect-to-exchange-2010.aspx.

I have tested my application against different 2010 exchange server  which has public folders and it works fine. I can open default store on other exchange server 2010 using MFCMapi but not on exchange server which does not have Public folders.

Any suggestions, please....

Nov 25, 2011 at 11:01 AM

Hi everyone,

I have this exact error as well as error 0x81002746 on ConfigureMsgService while creating profile with my own application.

ConfigureMsgService error com_error: (-2130696378, 'OLE error 0x81002746', None, None)

We have a MAPI based application that fails while creating profile for the user.
The call that fails is ConfigureMsgService error code : 0x81002746.

While trying to troubleshoot I used MFCMapi application to test exchange connectivity and its able to create profile
but it fails while opening the msg store with "MAPI_E_FAILONEPROVIDER == 0x8004011D" from OpenMsgStore call
in this particular exchange environment.

The exchange environment is exchange 2010 on 2008 server.
Its a DAG setup with two mailbox servers and CAS and Hub transport role on third machine.
This setup does not have public folder database.

I came across following blogs and have performed steps mentioned there.
1) The Elusive 0x81002746 Error
http://blogs.msdn.com/b/stephen_griffin/archive/2011/10/13/the-elusive-0x81002746-error.aspx
2) Did set CONNECT_IGNORE_NO_PF flag in profile as the public folders are not present.
http://blogs.msdn.com/b/stephen_griffin/archive/2007/03/19/mapi-and-exchange-2007.aspx
3) MAPI and IPv6 issues
http://blogs.msdn.com/b/stephen_griffin/archive/2008/08/15/mapi-and-ipv6.aspx
http://blogs.msdn.com/b/stephen_griffin/archive/2009/01/28/more-issues-with-mapi-and-ipv6.aspx

I have checked:
1) Application is running as service with users credentials ( domain user with full access permisions on mailbox)
1) The mailbox for user exist and user is mail enabled.
2) The database hosting the mailbox is mounted.
3) Mailbox is not hidden from GAL
4) There is only one GAL - Default Global Address List - present and user is member of that GAL
5) User has required privilege to access mailbox (we are trying to logon to user's own mailbox, but still manually
   added full access permissions as well as user is part of Domain administrator group , local administrator,
   exchange trusted sub system, has organization management rights )
6) Microsoft Information Store service is running as well as Microsoft Exchange System Attendant service is running.
7) IPv6 is disabled in the network control panel but as described in MAPI and IPv6 issues blog link above,
   we have asked to disable that completely in the registry (dont know the results yet)
8) We tried all above steps with two different user accounts.
9) Tried uninstalling and reinstalling MAPICDO library (latest version 6.5.8244.0)

Please let me know what else I should check for :
1) Our application is not able to create profile in configuremsgservice with error 0x81002746 but MFCMAPI can create the profile,
2) MFC mapi can not open the message store with OpenMsgStore error 0x8004011D failone provider.

(Please note I am a developer and not exchange administrator but have some knowledge on using powershell and exchange commands the application works fine in our test labs and some other exchange setups.)

Any help is appricieted.

Thanks.

Aug 23, 2012 at 5:03 PM

I'm having the same issue. Were you able to figure it out?

Aug 24, 2012 at 2:01 PM

In our case the solution was as follows:

“In case anyone runs into the issue that our company had, a registry key was set on the server blocking older Outlook clients access to the exchange server (HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem) Disable MAPI Clients = -10.0.0. The EMSMDB32.dll file which is installed with the MAPI Client and Collaboration Data Objects 1.2.1 is at version 6.5.8244.0 which was blocked by the key. More info can be found here:

http://technet.microsoft.com/en-us/library/aa996848%28EXCHG.80%29.aspx

From: molotov69 [email removed]
Sent: Thursday, August 23, 2012 6:19 PM
To: Thorne, Michael
Subject: Re: "MAPI_E_FAILONEPROVIDER == 0x8004011D" from OpenMsgStore with special exchange environment. [MFCMAPI:275489]

From: molotov69

I'm having the same issue. Were you able to figure it out?

Aug 24, 2012 at 3:01 PM

our organization is on Exchange 2010 and i can connect using outlook 2007, just not programatically. do you think this still applies?

Apr 12, 2013 at 4:19 PM
HI
I'm facing the same issue here , has anyone ever found a fix ?
thanks