MAPI_E_CALL_FAILED == 0x80004005 Opening Public Folders

Feb 16, 2011 at 1:05 PM

Hello,

 

I have an Exchange 2007 SP2 Rollup 5 w/CDO 1.2.1 on W2K3 server.

I am using MFCMAPI to restore deleted folders in my Public folders Store. When I connect to the server and open the public folders I get the following error message.

Error: Couldn't get property list from object
Code: MAPI_E_CALL_FAILED == 0x80004005
Function (null)
File .\MAPIFunctions.cpp
Line 1170

I am able to open the public folders and view the deleted folders yet I am unable to restore them. I get another mapi error.

OnRestoreDeletedFolder did not complete because CopyFolder failed.
There are a few known causes for this.
1 - The user does not have permissions. Try again with an administrative account.
    See http://support.microsoft.com/kb/262054
2 - Public folders were not opened with administrative permissions.
Use 'Open Public Folder Store...' on the MDB menu and check 'Use Admin Privileges' to open the Public Folder store.
3 - There may be corruption or invalid permissions on the deleted folders.
Display the ACL Table for the folder.  Look for DNs that don't resolve.  If so, consider temporarily recreating objects that match the DNs exactly.
4 - The folder being restored is in a Public Folder store and the virus scanner was updated after the folder was deleted.
 
Either use OWA to restore the folder or disable virus scanning to allow the folder to be restored
In file .\MsgStoreDlg.cpp
On line 1232

I have used the Domain admin account as well as a user account in the exchange Admin group. I tried on the server as well as on a workstation with out look 2007 installed and one with outlook 2010 installed. Any hints tips advice you could provide would be greatly appreciated.

 

Thanks,

enem

Coordinator
Feb 16, 2011 at 1:17 PM

Have you tried any of the four suggestions listed in the error?

Feb 16, 2011 at 2:08 PM

1) I have tried with an administrative domain account and from a domain user account that was added to the exchange administrators group.

2) I select Session -->Logon and Display Store Table. I am presented with Public Folders and Mailbox-Administrator. I left Click once on Public Folders to select it and am presented with the first error. I click ok and select MDB -->Open Public Folder store. I am presented with a Window for OPen Public Folder store which shows me Hex Codes for Entry flags for CreateStoreEntryID. I am assuming I chang the code to 0x00000001 for Admin Privileges. (I may be interpreting this wrong). Same result.

3) The ACL Tables look good. 

4) I removed Symantec EPM from the server.

I cannot see the deleted folders in OWA.

 

I should also mention that this is in the middle of a migration to Exch 2010. The user mailboxes were moved to 2010 and Replication to 2010 had been in place for weeks. When I requested my tech to decommission the server he failed to remove replication between the servers before deleting the public folders on the 2007 server. He then removed the mailbox store from the machine. I noticed the public folders were gone and stopped him before any further damage could be done. This public folders database is not default. This may be a symptom of part idiot and part density.

 

Thank You,

enem

Coordinator
Feb 16, 2011 at 2:13 PM

This may be a good time to look at restoring from backup. You might consider opening a case to see if our Admin engineers can figure out a way to get the data, or if it's even there to get.

Feb 16, 2011 at 2:21 PM

OK how would I open a case?

Coordinator
Feb 16, 2011 at 2:26 PM

http://support.microsoft.com

Feb 16, 2011 at 2:34 PM

Oh, you are part of Microsoft in some way? I apologize for that. I will try that . I may have a couple of incidences remaining on my subscription.

 

Thank You.

Coordinator
Feb 16, 2011 at 2:48 PM

Yeah - I'm an Escalation Engineer on the Developer Support team supporting the APIs that I use in MFCMAPI.

Feb 16, 2011 at 3:20 PM

Ok. I have an update. I dismounted the public store to copy it to another folder before I restored a backup. I then attempted MFCMAPI again to see how the program would act and what responses would be given. I noticed I received the exact same responses. I felt at that point that something was not right since that data store was offline. I could not see how to connect to a specific public database per server.  I will look into the use of MFCMAPI further and become more familiar with it.

Anyway I went back to my 2010 server and opened ExFolders app. I then could see the public folders. I right clicked it and viewed deleted folders. they were displayed in red. I am restoring them now.

 

Thank You for your help on this. I will continue to play and research this strange behaviour to better understand exactly what happened and why.